Setting Access Point Hotspot

Setting Access Point Hotspot

Setting Access Point Hotspot -  Pada tutorial sebelumnya kita sudah belajar bagai mana menseting router hotspot di Mikrotik. Oleh sebab itu untuk dapat mengikuti tutorial ini dengan baik, maka perlu anda pahami terlebih dahulu tentang cara setting router hotspot pada tutorial tersebut. Pada tutorial kali ini kita akan mencoba mengsetting sebuah access point yang nantinya akan digunakan sebagai pemancar hotspot kepada user yang akan menggunakannya.

Setting Access Point Hotspot

Sebelum kita melanjutkan ke tahap configurasi seperti biasanya kita akan membuat topologi jaringan yang akan kita buat, ini tujuanya untuk mempermudah kita melakukan konfigurasi dan berikut topologinya :

Setting Access Point Hotspot

Penjelasan gambar :
1. Pada topologi di atas terlihat bahwasanya interface yang bertindak sebagai WAN (yang terhubung ke internet) adalah ether2, karena interface inilah yang dihubungkan ke jaringan yang terkoneksi internet untuk di sebarkan kembali kepada user yang ingin menggunakan hotspot nantinya,
2. Kemudian di sana ada Ether3, yang mana interface ini dihubungkan ke access point,
3. Selain itu ada Vlan-10 dan Vlan-100.
Sedikit informasi tentang Vlan dikutip dari wiki :
Virtual LAN atau disingkat VLAN merupakan sekelompok perangkat pada satu LAN atau lebih yang dikonfigurasikan (menggunakan perangkat lunak pengelolaan) sehingga dapat berkomunikasi seperti halnya bila perangkat tersebut terhubung ke jalur yang sama, padahal sebenarnya perangkat tersebut berada pada sejumlah segmen LAN yang berbeda. Vlan dibuat dengan menggunakan jaringan pihak ke tiga. VLAN merupakan sebuah bagian kecil jaringan IP yang terpisah secara logik. VLAN memungkinkan beberapa jaringan IP dan jaringan-jaringan kecil (subnet) berada dalam jaringan switched switched yang sama.

Jadi, bahasa singkatnya yaitu Vlan ini merupakan singkatan dari virtual LAN, yang mana merupakan interface virtual dan dihubungkan dengan ID tunnel yang sama (jika beda tunnel ID maka antar vlan tidak bisa berkomunikasi, jadi misalnya Vlan10 di satu perangkat hanya bisa berkomunikasi dengan Vlan10 di perangkat lain yang berada di dalam satu segment [layer2] ), jadi dengan seperti itu maka di satu interface hardware ethernet, jika kita menambahkan 10 buah Vlan maka seakan-akan kita mempunyai 10 interface yang berbeda dan dapat kita setting IP di masing-masing interface tersebut.

Jadi, pada topologi di atas kita mempunyai 2 Vlan yaitu Vlan dengan ID 10 dan Vlan dengan ID 100 dan ini perlu ditambahkan di masing-masing perangkat yaitu baik di sisi router hotspot maupun di sisi access point.

Vlan dengan ID 10 ini nanti akan kita gunakan sebagai interface management access pointnya dan Vlan dengan ID 100 akan kita gunakan sebagai interface untuk hotspotnya, sehingga di sisi access point nanti perlu kita melakukan bridge antara Vlan ID 100 dan wlan, tujuannya agar ketika ada user yang joint ke wlan maka akses internetnya akan menggunakan dari koneksi yang melewati Vlan ID 100 ini dan di sisi router hotspot interface yang akan kita jadikan hotspot yaitu interface yang Vlan dengan ID 100.

4. Jadi, alurnya yaitu :
----->>Jaringan internet yang ada di HUB akan masuk melalui ether2,
----->>Kemudian di dalam router hotspotnya akan di olah, kemudian akan dikeluarkan untuk disebarkan kepada user melalui Vlan dengan ID 100 yang berada di etehr3,
----->>Setelah itu, akan masuk ke access point, setelah masuk ke access point, maka sekarang tugasnya access point untuk memancarkan signal hotspotnya kepada device user,
----->>Kemudian setelah signal hotspotnya di pancarkan oleh access point maka ketika ada user yang ingin joint ke nama SSID hotspot yang ada maka device user tersebut akan terkoneksi melalui wireless access point dan mendapatkan settingan IP secara otomatis melalui dhcp yang telah diaktifkan di interface dengan Vlan ID 100 yang ada di router hotspot.

Konfigurasi

Karena pada tutorial sebelumnya yaitu Tutorial Setting Mikrotik Router Hotspot kita sudah membahas bagaimana cara setting router hotspot maka pada tutorial kali ini kita hanya berfokus pada cara setting access pointnya saja, jika masih ragu dengan cara setting router hotspot maka saya sarankan anda mencoba memahami kembali tutorial tersebut.

Berikut konfigurasi yang harus kita lakukan di sisi Mikrotik Router Hotspot :

Seperti yang saya informasikan di atas tadi pada tutorial ini kita tidak akan membahas secara details konfigurasi Mikrotik router hotspot, jadi saya akan informasikan secara garis besar saja untuk konfigurasinya, untuk lebih detailsnya bisa mengakses kembali tutorial router hotspot sebelumnya.

0. Konfigurasi Router Hotspot

Berikut adalah garis besar yang harus anda lakukan untuk konfigurasi router hotspot :
a. Silahkan akses mikrotik router hotspot anda,
b. Selanjutnya silahkan anda menambahkan 2 buah Vlan di ether3 (interface yang nantinya akan kita colok access point) yaitu Vlan dengan ID 10 untuk management AP dan Vlan dengan ID 100 untuk Hotspot,
c. Kemudian silahkan anda berikan IP WAN yaitu 192.168.2.244/24 sebagai IP yang terhubung ke internet ke ether2 (interface yang terhubung ke jaringan internet, jadi sesuaikan dengan nama interface yang anda gunakan),
d. Silahkan anda tambahkan gatewaynya,
e. Silahkan anda berikan IP 192.168.0.1/24 (untuk IP ini bisa anda isi dengan IP lain jadi sesuaikan dengan IP yang akan anda gunakan) di interface Vlan dengan ID 10, ini berfungsi untuk IP management access pointnya,
f. Selanjutnya, silahkan anda berikan IP 192.168.14.1/24 (untuk IP ini bisa anda isi dengan IP lain jadi sesuaikan dengan IP yang akan anda gunakan) di interface Vlan dengan ID 100, ini berfungsi untuk IP hotspot yang nantinya akan didapatkan oleh user ketika mereka joint ke SSID hotspot yang dipancarkan oleh access point,
g. Kemudian silahkan anda berikan DNS routernya, agar bisa resolv atau ngeping ke domain,
h. Selanjutnya setting DHCP server menggunakan interface Vlan dengan ID 100,
i. Selanjutnya setting Hotspot server menggunakan interface Vlan dengan ID 100,

Kurang lebih seperti gambar berikut ini :
Setting Access Point Hotspot

Sampai tahap ini, jika anda melakukannya dengan benar maka untuk konfigurasi router sudah selesai dan saatnya kita melanjutkan untuk konfigurasi access pointnya.

Berikut konfigurasi yang harus kita lakukan di sisi access point :

1. Jika type AP yang digunakan adalah 1XPYL751 maka berikut konfigurasinya :

------>>Pertama pastikan anda bisa ping ke IP APnya, jika anda tidak tahu IPnya berapa maka bisa anda mencoba ping ke IP defaultnya, umumnya IP defaultnya yaitu 192.168.1.1, jika tidak reply juga maka disarankan untuk melakukan reset pada AP tersebut agar konfigurasinya menjadi default,

------>>Jika anda sudah bisa ping, langkah selanjutnya yaitu akses ke APnya melalui SSH menggunakan aplikasi putty, jika belum mempunya aplikasi putty anda bisa mendownloadnya melalui link berikut ini : https://the.earth.li/~sgtatham/putty/latest/x86/putty.exe. Jika sudah silahkan jalankan aplikasi puttynya dan ketik IP Address AP di bagian Host Name (or IP address), lalu dibagian Connection type pilih SSH dan port 22, kemudian pilih dan tekan tombol Open, kurang lebih tampilannya sebagai berikut ini :

Setting Access Point Hotspot

Jika berhasil akses maka akan muncul form login seperti berikut ini, silahkan login dengan user root dan password sesuai dengan password AP yang anda miliki :

Setting Access Point Hotspot
Note : Jika APnya belum ada password maka anda tidak bisa login dari SSH jadi disarankan untuk mensetting passwordnya terlebih dahulu dengan cara, silahkan anda akses dari browser IP APnya (192.168.1.1) dan kemudian setting passwordnya dari sana (sesuai instruksi yang muncul pada halaman webnya).

------>>Selanjutnya jika sudah berhasil login maka langkah selanjutnya yaitu mengkonfigurasi networknya dengan cara :
ketik perintah ini pada layar consolenya :
root@1XP:~# vi /etc/config/network
Kemudian sesuaikan isinya seperti berikut ini :

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.100'
option type 'bridge'
option proto 'static'

config interface 'wan'
option ifname 'eth0.10'
option proto 'static'
option ipaddr '192.168.0.2'
option netmask '255.255.255.0'
option gateway '192.168.0.1'

config switch
option name 'mt7620'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'mt7620'
option vlan '1'
option ports '1 2 3 4 5 6t'

config switch_vlan
option device 'mt7620'
option vlan '3'
option ports '0t 6t'
option vid '10'

config switch_vlan
option device 'mt7620'
option vlan '4'
option ports '0t 6t'
option vid '100'

Kemudian jika semua sudah sesuai (khusus untuk IP address dan Gateway, silahkan anda sesuaikan dengan jaringan anda), silahkan anda save dengan cara : tekan tombol Esc pada keyboard anda, kemudian tekan tombol kombinasi Shift+: (tekan tombol shift dan tombol titik dua secara bersamaan) setelah itu ketik huruf wq, kemudian tekan tombol enter (ingat tombol enter yach jangan tombol entar, kalo entar kelamaan ^_^).

------>>Langah selanjutnya yaitu mengkonfigurasi wirelessnya dengan cara :
ketik perintah ini pada layar consolenya :
root@1XP:~# vi /etc/config/wireless
Kemudian sesuaikan isinya seperti berikut ini :

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path '10180000.wmac'
option country 'US'
option channel '5'
option htmode 'HT40'
option txpower '17'
option noscan '1'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid '@Nama-Hotspot-Anda'
option encryption 'none'

Kemudian jika semua sudah sesuai, silahkan anda save dengan cara : tekan tombol Esc pada keyboard anda, kemudian tekan tombol kombinasi Shift+: (tekan tombol shift dan tombol titik dua secara bersamaan) setelah itu ketik huruf wq, kemudian tekan tombol enter.

------>>Langah selanjutnya yaitu mengizinkan akses melalui port WAN di firewallnya dengan cara :
ketik perintah ini pada layar consolenya :
root@1XP:~# vi /etc/config/firewall
Kemudian cari baris config zone seperti yang di bawah ini dan pastikan rubah nilai REJECT ke ACCEPT :

config zone
option name             wan
list   network          'wan'
list   network          'wan6'
option input            ACCEPT
option output           ACCEPT
option forward          ACCEPT
option masq             1
option mtu_fix          1

Kemudian jika semua sudah sesuai, silahkan anda save dengan cara : tekan tombol Esc pada keyboard anda, kemudian tekan tombol kombinasi Shift+: (tekan tombol shift dan tombol titik dua secara bersamaan) setelah itu ketik huruf wq, kemudian tekan tombol enter.

------>>Langah selanjutnya yaitu silahkan anda jalankan perintah ini pada layar consolenya :
root@1XP:~# /etc/init.d/network restart

Perintah tersebut berfungsi untuk merestart service networknya agar konfigurasi yang barusan kita lakukan dapat diterapkan pada system access point tersebut.

Testing

Langkah selanjutnya setelah semuanya selesai kita konfigurasi yaitu melakukan testing untuk memastikan konfigurasi kita sudah benar atau belum.

Untuk step testingnya yaitu sebagai berikut ini :

------>>Masuk ke Mikrotik router hotspot anda, kemudian silahkan ping ke IP access point anda (192.168.0.2) melalui new terminal, seperti gambar di bawah ini :
Setting Access Point Hotspot

Jika hasilnya reply seperti di atas maka itu artinya semua berjalan dengan baik, namun jika tidak reply, silahkan anda check perkabelan yang dipakai dan juga konfigurasi router hotspot dan access point anda (khususnya settingan vlan dan IP address dan interfacenya),

------>>Selanjutnya jika dari router hotspot sudah bisa ping ke IP access point, sekarang kita coba test akses ke APnya melalui new terminal di Mikrotik router hotspot dengan cara sebagai berikut :
Buka new terminal pada Mikrotik router hotspotnya dan ketik perintah berikut ini :
Setting Access Point Hotspot

Setelah itu akan muncul form isi password, silahkan anda isikan password AP yang telah anda setting pada tahap awal tadi, jika anda berhasil login berarti konfigurasi anda sudah benar, selanjutnya silahkan ketik perintah ini :
root@1XP:~# brctl show
Jika hasilnya seperti berikut ini :
Setting Access Point Hotspot
Maka itu artinya konfigurasi anda sudah benar.

------>>Selanjutnya, jika testing secara konfigurasi sudah benar semua, sekarang saatnya kita melakukan test joint, silahkan laptop atau handphone anda mencoba joint ke SSID hotspot yang telah anda setting tadi, jika device anda bisa joint dan berhasil mendapatkan IP 192.168.14.* dengan gateway 192.168.14.1, selanjutnya silahkan test browsing misalnya dengan mencoba akses detik.com dari browser anda, jika muncul login page itu artinya anda sudah berhasil melakukan konfigurasi, silahkan anda login sesuai dengan user dan password hotspot yang telah anda created di router hotspot anda.

2. Jika type AP yang digunakan adalah 1XPRT751U maka berikut konfigurasinya :

Jika kita menggunakan Access Point dengan type 1XPRT751U, secara konfigurasi dan step sama dengan tahap di atas tadi, yang membedakan hanya isi file yang /etc/config/network saja, jadi jika anda menggunakan Access Point dengan type 1XPRT751U maka anda bisa mengikuti step by step di atas dan khusus untuk isi file /etc/config/network anda harus sesuaikan seperti berikut ini :

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth2.2.100'
option type 'bridge'
option proto 'static'

config interface 'wan'
option ifname 'eth2.2.10'
option proto 'static'
option ipaddr '192.168.0.2'
option netmask '255.255.255.0'
option gateway '192.168.0.1'

config switch
option name 'mt762x'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'mt762x'
option vlan '1'
option ports '0 1 2 3 5 6t'

config switch_vlan
option device 'mt762x'
option vlan '2'
option ports '4 6t'

Kemudian jika semua sudah sesuai, silahkan anda save dengan cara : tekan tombol Esc pada keyboard anda, kemudian tekan tombol kombinasi Shift+: (tekan tombol shift dan tombol titik dua secara bersamaan) setelah itu ketik huruf wq, kemudian tekan tombol enter.

Untuk step-step dan konfigurasi yang lainnya sama persis seperti step yang di atas tadi. Jadi, yang membedakan konfigurasi antara unit dengan type 1XPRT751U dengan unit type 1XPYL751 hanya ada di file /etc/config/network saja.

Sekian tutorial singkat ini , selamat mencoba dan semoga berhasil.

 

Sukses selalu untuk anda